Creates one conduit standard type with the new name and assign the conduit sizes to it from the existing standard type.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pADoc
- Type: Autodesk.Revit.DB Document
The document.
- newStandardName
- Type: System String
The new conduit standard name.
- existingStandardName
- Type: System String
The existing conduit standard name.
Return Value
True if creating success; otherwise false.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The conduit standard name already exists. -or- The conduit standard name does not exist. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |