Conduit |
Creates one conduit standard type with the new name and assign the conduit sizes to it from the existing standard type.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public bool CreateConduitStandardTypeFromExisingStandardType(
Document pADoc,
string newStandardName,
string existingStandardName
)
Parameters
- pADoc Document
- The document.
- newStandardName String
- The new conduit standard name.
- existingStandardName String
- The existing conduit standard name.
Return Value
BooleanTrue if creating success; otherwise false.

Exception | Condition |
---|---|
ArgumentException | The conduit standard name already exists. -or- The conduit standard name does not exist. |
ArgumentNullException | A non-optional argument was null |