Return the parameter's default value as stored in the definition.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
- Type: Autodesk.Revit.DB ElementId
Id of a parameter in the definition.
Return Value
The parameter value.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |