Returns the normal vector for the face at the given point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB UV
The parameters to be evaluated, in natural parameterization of the face.
Return Value
The normal vector. This vector will be normalized.Remarks
Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of a solid that contains the face.