The FilteredElementCollector type exposes the following members.
Constructors
Name | Description | |
---|---|---|
![]() | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document. |
![]() | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view. |
![]() | FilteredElementCollector(Document, ICollection ElementId ) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements. |
Methods
Name | Description | |
---|---|---|
![]() | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector. |
![]() | Dispose | Releases all resources used by the FilteredElementCollector |
![]() | Equals | (Inherited from Object .) |
![]() | Excluding | Applies an ExclusionFilter to the collector. |
![]() | FirstElement | Returns the first element to pass the filter(s). |
![]() | FirstElementId | Returns the id of the first element to pass the filter(s). |
![]() | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetElementCount | Gets the number of elements in your current filter. |
![]() | GetElementIdIterator | Returns an element id iterator to the elements passing the filters. |
![]() | GetElementIterator | Returns an element iterator to the elements passing the filters. |
![]() | GetEnumerator | Returns an enumerator that iterates through a collection. |
![]() | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object .) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object .) |
![]() | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector. |
![]() ![]() | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements. |
![]() | OfCategory | Applies an ElementCategoryFilter to the collector. |
![]() | OfCategoryId | Applies an ElementCategoryFilter to the collector. |
![]() | OfClass | Applies an ElementClassFilter to the collector. |
![]() | OwnedByView | Applies an ElementOwnerViewFilter to the collector. |
![]() | ToElementIds | Returns the complete set of element ids that pass the filter(s). |
![]() | ToElements | Returns the complete set of elements that pass the filter(s). |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object .) |
![]() | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector. |
![]() | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector. |
![]() | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector. |
![]() | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector. |
![]() | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector. |
![]() | WherePasses | Applies an element filter to the collector. |
Properties
Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |