FilteredElementCollector Members


The FilteredElementCollector type exposes the following members.

Constructors

  NameDescription
Public methodFilteredElementCollector(Document)
Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public methodFilteredElementCollector(Document, ElementId)
Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public methodFilteredElementCollector(Document, ICollectionElementId)
Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Public methodFilteredElementCollector(Document, ElementId, ElementId)
Constructs a new FilteredElementCollector that will search and filter the visible elements from a Revit link in a host document view.

Methods

  NameDescription
Public methodContainedInDesignOption
Applies an ElementDesignOptionFilter to the collector.
Public methodDispose
Releases all resources used by the FilteredElementCollector
Public methodEquals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Public methodExcluding
Applies an ExclusionFilter to the collector.
Public methodFirstElement
Returns the first element to pass the filter(s).
Public methodFirstElementId
Returns the id of the first element to pass the filter(s).
Protected methodGetBasicIEnumerator
Returns an enumerator that iterates through a collection.
Public methodGetElementCount
Gets the number of elements in your current filter.
Public methodGetElementIdIterator
Returns an element id iterator to the elements passing the filters.
Public methodGetElementIterator
Returns an element iterator to the elements passing the filters.
Public methodGetEnumerator
Returns an enumerator that iterates through a collection.
Public methodGetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public methodGetType
Gets the Type of the current instance.
(Inherited from Object.)
Public methodIntersectWith
Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public methodStatic memberIsViewValidForElementIteration
Identifies if the particular element is valid for iteration of drawn elements.
Public methodOfCategory
Applies an ElementCategoryFilter to the collector.
Public methodOfCategoryId
Applies an ElementCategoryFilter to the collector.
Public methodOfClass
Applies an ElementClassFilter to the collector.
Public methodOwnedByView
Applies an ElementOwnerViewFilter to the collector.
Public methodToElementIds
Returns the complete set of element ids that pass the filter(s).
Public methodToElements
Returns the complete set of elements that pass the filter(s).
Public methodToString
Returns a string that represents the current object.
(Inherited from Object.)
Public methodUnionWith
Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public methodWhereElementIsCurveDriven
Applies an ElementIsCurveDrivenFilter to the collector.
Public methodWhereElementIsElementType
Applies an ElementIsElementTypeFilter to the collector.
Public methodWhereElementIsNotElementType
Applies an inverted ElementIsElementTypeFilter to the collector.
Public methodWhereElementIsViewIndependent
Applies an ElementOwnerViewFilter to the collector.
Public methodWherePasses
Applies an element filter to the collector.

Properties

  NameDescription
Public propertyIsValidObject
Specifies whether the .NET object represents a valid Revit entity.

See Also