GetActiveSunAndShadowSettings Method


Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011

Syntax

C#
public static Element GetActiveSunAndShadowSettings(
	Document aDocument
)
Visual Basic
Public Shared Function GetActiveSunAndShadowSettings ( _
	aDocument As Document _
) As Element
Visual C++
public:
static Element^ GetActiveSunAndShadowSettings(
	Document^ aDocument
)

Parameters

aDocument
Type: Autodesk.Revit.DB Document
The document.

Return Value

The active SunAndShadowSettings element for the supplied document.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also