GetActiveSunAndShadowSettings Method


Sun And Shadow Settings Get Active Sun And Shadow Settings Method

Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Element GetActiveSunAndShadowSettings(
	Document aDocument
)

Parameters

aDocument Document
The document.

Return Value

Element
The active SunAndShadowSettings element for the supplied document.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also