AreOptionsValid Method


Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2021

Syntax

C#
public bool AreOptionsValid(
	DirectShapeTypeOptions options
)
Visual Basic
Public Function AreOptionsValid ( _
	options As DirectShapeTypeOptions _
) As Boolean
Visual C++
public:
bool AreOptionsValid(
	DirectShapeTypeOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB DirectShapeTypeOptions
The options object.

Return Value

True if the DirectShapeTypeOptions are valid; false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also