Checks whether the family symbol id is allowed for Analytical Member as Section Type property.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familySymbolId
- Type: Autodesk.Revit.DB ElementId
Family symbol id which has to be checked.
Return Value
True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Structural Framing" (OST_StructuralFraming) or "Structural Columns" (OST_StructuralColumns) Returns false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |