Analytical |
Checks whether the family symbol id is allowed for Analytical Member as Section Type property.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familySymbolId ElementId
- Family symbol id which has to be checked.
Return Value
BooleanTrue if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Structural Framing" (OST_StructuralFraming) or "Structural Columns" (OST_StructuralColumns) Returns false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |