OnOpenConflict Method


A method called when the conflict is happen during the model opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019

Syntax

C#
OpenConflictResult OnOpenConflict(
	OpenConflictScenario scenario
)
Visual Basic
Function OnOpenConflict ( _
	scenario As OpenConflictScenario _
) As OpenConflictResult
Visual C++
OpenConflictResult OnOpenConflict(
	OpenConflictScenario scenario
)

Parameters

scenario
Type: Autodesk.Revit.DB OpenConflictScenario
The scenario of the conflict.

Return Value

Returns the result to indicate whether to keep the unsynchronized change, or open the latest version or cancel the open action.

See Also