Move the circuits in the source slot to the specific slot.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nMovingRow
- Type: System Int32
The Row Number of cell to be moved.
- nMovingCol
- Type: System Int32
Start Column Number of cell to be moved.
- nToRow
- Type: System Int32
The Row Number of cell to moved to.
- nToCol
- Type: System Int32
End Column Number of cell to moved to.
Remarks
If the moving circuit is in a group, all circuits in the group will be moved accordingly.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given row number nMovingRow is invalid in Body. -or- The given column number nMovingCol is invalid in Body. -or- The given row number nToRow is invalid in Body. -or- The given column number nToCol is invalid in Body. -or- There is no circuit at given cell (nMovingRow, nMovingCol). -or- Cannot move the circuits at slot (nMovingRow, nMovingCol) to given slot (nToRow, nToCol). |