Returns an object for managing view crop region shape for reference callout.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
Document to which the callout belongs.
- callout
- Type: Autodesk.Revit.DB ElementId
Element id of reference callout.
Return Value
The crop region shape manager.Remarks
Reference callout is a view-specific element referencing another view. It can have its own crop region shape which doesn't affect the referenced view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |