View Get |
Returns an object for managing view crop region shape for reference callout.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static ViewCropRegionShapeManager GetCropRegionShapeManagerForReferenceCallout(
Document doc,
ElementId callout
)
Parameters
- doc Document
- Document to which the callout belongs.
- callout ElementId
- Element id of reference callout.
Return Value
ViewCropRegionShapeManagerThe crop region shape manager.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Reference callout is a view-specific element referencing another view. It can have its own crop region shape which doesn't affect the referenced view.