Returns the face to which the RebarConstraint is attached associated to the given target index. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.'
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetIndex
- Type: System Int32
The index of the target. Should be between 0 and NumberOfTargets().
- faceTransform
- Type: Autodesk.Revit.DB Transform
Returns the transform that is associated to the face's element geometry.
Return Value
Requested Face.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | targetIndex is out of range. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover.' |