GetTargetHostFaceAndTransform Method


Rebar Constraint Get Target Host Face And Transform Method

Returns the face to which the RebarConstraint is attached associated to the given target index. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover'.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Face GetTargetHostFaceAndTransform(
	int targetIndex,
	Transform faceTransform
)

Parameters

targetIndex Int32
The index of the target. Should be between 0 and NumberOfTargets().
faceTransform Transform
Returns the transform that is associated to the face's element geometry.

Return Value

Face
Requested Face.
Exceptions
Exception Condition
ArgumentException targetIndex is out of range.
ArgumentNullException A non-optional argument was null
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'.
See Also