MechanicalSystemType Class


Base class for duct system types

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public class MechanicalSystemType : MEPSystemType
Visual Basic
Public Class MechanicalSystemType _
	Inherits MEPSystemType
Visual C++
public ref class MechanicalSystemType : public MEPSystemType

Inheritance Hierarchy

System Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB ElementType
Autodesk.Revit.DB MEPSystemType
Autodesk.Revit.DB.Mechanical MechanicalSystemType

See Also