MechanicalSystemType Class


Base class for duct system types

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public class MechanicalSystemType : MEPSystemType
Visual Basic
Public Class MechanicalSystemType _
	Inherits MEPSystemType
Visual C++
public ref class MechanicalSystemType : public MEPSystemType

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBMEPSystemType
        Autodesk.Revit.DB.MechanicalMechanicalSystemType

See Also