Adds a trigger to an updater with specified set of elements and ChangeType
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.DB UpdaterId
Id of updater that trigger should be added to
- document
- Type: Autodesk.Revit.DB Document
Document that elements in 'elements' are contained in
- elements
- Type: System.Collections.Generic ICollection ElementId
Set of elements which define this trigger
- change
- Type: Autodesk.Revit.DB ChangeType
ChangeType associated with this trigger
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | updater's owner AddIn does not match the currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater. |