AddTrigger Method (UpdaterId, Document, ICollection(ElementId), ChangeType)


Updater Registry Add Trigger(Updater Id, Document, ICollection Element Id , Change Type) Method

Adds a trigger to an updater with specified set of elements and ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void AddTrigger(
	UpdaterId id,
	Document document,
	ICollection<ElementId> elements,
	ChangeType change
)

Parameters

id UpdaterId
Id of updater that trigger should be added to
document Document
Document that elements in 'elements' are contained in
elements ICollection ElementId
Set of elements which define this trigger
change ChangeType
ChangeType associated with this trigger
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException updater's owner AddIn does not match the currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.
See Also