Moves the ImageInstance to the specified location
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- newLocation
- Type: Autodesk.Revit.DB XYZ
The new location of the specified point
- placementPoint
- Type: Autodesk.Revit.DB BoxPlacement
The placementPoint specifies which point of the ImageInstance should be placed at the given location.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given newLocation is more than 10 miles from the origin of the model |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |