SetLocation Method


Image Instance Set Location Method

Moves the ImageInstance to the specified location

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLocation(
	XYZ newLocation,
	BoxPlacement placementPoint
)

Parameters

newLocation XYZ
The new location of the specified point
placementPoint BoxPlacement
The placementPoint specifies which point of the ImageInstance should be placed at the given location.
Exceptions
Exception Condition
ArgumentException The given newLocation is more than 10 miles from the origin of the model
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also