Dissolves a collection of form elements into their defining elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The document
- elements
- Type: System.Collections.Generic ICollection ElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
Return Value
A collection of curve element ids from the profiles and paths of the dissolved forms.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The elements do not include Forms that can be dissolved. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |