DissolveForms Method (Document, ICollection(ElementId))


Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static ICollection<ElementId> DissolveForms(
	Document ADoc,
	ICollection<ElementId> elements
)
Visual Basic
Public Shared Function DissolveForms ( _
	ADoc As Document, _
	elements As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
	Document^ ADoc, 
	ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DBDocument
The document
elements
Type: System.Collections.GenericICollectionElementId
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The elements do not include Forms that can be dissolved.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also