Sets whether the RebarConstrainedHandle to target offset is the clear bar distance, or is measured between bar centers.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- useClearBarSpacing
- Type: System Boolean
True if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.
Remarks
Throw exception if it's used on start/end handle to start/end handle constraint, and on constraints involving bar/hook bend handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarConstraint constrain two Rebar ends. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |