SetToUseClearBarSpacing Method


Rebar Constraint Set To Use Clear Bar Spacing Method

Sets whether the RebarConstrainedHandle to target offset is the clear bar distance, or is measured between bar centers.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetToUseClearBarSpacing(
	bool useClearBarSpacing
)

Parameters

useClearBarSpacing Boolean
True if the RebarConstrainedHandle to target offset is the clear bar distance, false if the offset is measured between bar centers.
Exceptions
Exception Condition
InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The RebarConstraint constrain two Rebar ends. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
Remarks
Throw exception if it's used on start/end handle to start/end handle constraint, and on constraints involving bar/hook bend handle.
See Also