Stretch the fabrication part from the specified connector and fit to the target routing end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to perform the stretch and fit.
- stretchConnector
- Type: Autodesk.Revit.DB Connector
The connector of the fabrication part to be stretched.
- target
- Type: Autodesk.Revit.DB.Fabrication FabricationPartRouteEnd
The target routing end to align and fit to.
- newPartIds
- Type: System.Collections.Generic ISet ElementId %
New fabrication part element identifiers.
Return Value
Returns FabricationPartFitResult::Success if successful.Remarks
Cannot stretch and fit fabrication part straight, tap or hanger.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Connector does not belong to a fabrication part with a valid fabrication service. -or- Connector is connected. -or- Connector belongs to a fabrication part straight, tap or hanger. -or- routing end is valid to route to. -or- stretch target end type must be a supported type. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | fabrication part is not connected at one end only. -or- cannot stretch fabrication part to a different service. |