StretchAndFit Method


Fabrication Part Stretch And Fit Method

Stretch the fabrication part from the specified connector and fit to the target routing end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FabricationPartFitResult StretchAndFit(
	Document document,
	Connector stretchConnector,
	FabricationPartRouteEnd target,
	out ISet<ElementId> newPartIds
)

Parameters

document Document
The document in which to perform the stretch and fit.
stretchConnector Connector
The connector of the fabrication part to be stretched.
target FabricationPartRouteEnd
The target routing end to align and fit to.
newPartIds ISet ElementId
New fabrication part element identifiers.

Return Value

FabricationPartFitResult
Returns FabricationPartFitResult::Success if successful.
Exceptions
Exception Condition
ArgumentException Connector does not belong to a fabrication part with a valid fabrication service. -or- Connector is connected. -or- Connector belongs to a fabrication part straight, tap, or hanger. -or- Routing end is valid to route to. -or- stretch target end type must be a supported type.
ArgumentNullException A non-optional argument was null
InvalidOperationException fabrication part is not connected at one end only. -or- cannot stretch fabrication part to a different service.
Remarks
Cannot stretch and fit fabrication part straight, tap or hanger.
See Also