Checks if the input profile curve is valid to create a surface of revolution around the given axis.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- axisBasePoint
- Type: Autodesk.Revit.DB XYZ
The base point of the axis of revolution.
- axisDirection
- Type: Autodesk.Revit.DB XYZ
The direction of the axis.
- profileCurve
- Type: Autodesk.Revit.DB Curve
The profile curve.
Return Value
True if the profile curve is valid; False otherwise.Remarks
The validity is defined as follows:
- The profile curve is bounded and non-degenerate.
- It is co-planar with the axis of revolution.
- It lies on only one side of the axis.
- Only the end points of the profile curve can touch the axis.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |