IsValidProfileCurve Method (XYZ, XYZ, Curve)


Revolved Surface Is Valid Profile Curve(XYZ, XYZ, Curve) Method

Checks if the input profile curve is valid to create a surface of revolution around the given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidProfileCurve(
	XYZ axisBasePoint,
	XYZ axisDirection,
	Curve profileCurve
)

Parameters

axisBasePoint XYZ
The base point of the axis of revolution.
axisDirection XYZ
The direction of the axis.
profileCurve Curve
The profile curve.

Return Value

Boolean
True if the profile curve is valid; False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The validity is defined as follows:
  • The profile curve is bounded and non-degenerate.
  • It is co-planar with the axis of revolution.
  • It lies on only one side of the axis.
  • Only the end points of the profile curve can touch the axis.
See Also