Sets the characters in a given text range to be superscript or not superscript.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- textRange
- Type: Autodesk.Revit.DB TextRange
The given text range.
- isSuperscript
- Type: System Boolean
The desired superscript status of characters in the given text range. True to set superscript, false to set not superscript.
Remarks
Superscript and subscript are mutually exclusive. Applying the superscript status will automatically remove the subscript status.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |