SetSuperscriptStatus Method (TextRange, Boolean)


Formatted Text Set Superscript Status(Text Range, Boolean) Method

Sets the characters in a given text range to be superscript or not superscript.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSuperscriptStatus(
	TextRange textRange,
	bool isSuperscript
)

Parameters

textRange TextRange
The given text range.
isSuperscript Boolean
The desired superscript status of characters in the given text range. True to set superscript, false to set not superscript.
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks

Superscript and subscript are mutually exclusive. Applying the superscript status will automatically remove the subscript status.

The given text range should not be empty.

See Also