Constructs the effect instance for geometry having the specified vertex format.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexFormatBits
- Type: Autodesk.Revit.DB.DirectContext3D VertexFormatBits
The vertex format of the geometry to be used with this effect instance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This EffectInstance is not available because Revit is not currently rendering. In general, this EffectInstance must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |