EffectInstance Constructor


Effect Instance Constructor

Constructs the effect instance for geometry having the specified vertex format.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public EffectInstance(
	VertexFormatBits vertexFormatBits
)

Parameters

vertexFormatBits VertexFormatBits
The vertex format of the geometry to be used with this effect instance.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This EffectInstance is not available because Revit is not currently rendering. In general, this EffectInstance must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also