Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DB Reference
A candidate reference in selection operation.
- position
- Type: Autodesk.Revit.DB XYZ
The 3D position of the mouse on the candidate reference.
Return Value
Return true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.Remarks
If an exception is thrown from this method, the element will not be permitted to be selected.