ISelection |
Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- reference Reference
- A candidate reference in selection operation.
- position XYZ
- The 3D position of the mouse on the candidate reference.
Return Value
BooleanReturn true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.

If an exception is thrown from this method, the element will not be permitted to be selected.