Adds a new dockable pane to the Revit user interface.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.UI DockablePaneId
Unique identifier for the new pane.
- title
- Type: System String
String to use for the pane caption.
- provider
- Type: Autodesk.Revit.UI IDockablePaneProvider
Your add-in's implementation of the IDockablePaneProvider interface.
Examples

public Result OnStartup(UIControlledApplication application)
{
// Create our pane provider and register it with the application
PaneProvider prov = new PaneProvider();
DockablePaneId id = new DockablePaneId(Guid.NewGuid());
application.RegisterDockablePane(id, "test", prov);
return Result.Succeeded;
}

Public Function OnStartup(application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
' Create our pane provider and register it with the application
Dim prov As New PaneProvider()
Dim id As New DockablePaneId(Guid.NewGuid())
application.RegisterDockablePane(id, "test", prov)
Return Result.Succeeded
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if a dockable pane with identifier %id% has already been registered. |