UIControlled |
Adds a new dockable pane to the Revit user interface.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

public void RegisterDockablePane(
DockablePaneId id,
string title,
IDockablePaneProvider provider
)
Parameters
- id DockablePaneId
- Unique identifier for the new pane.
- title String
- String to use for the pane caption.
- provider IDockablePaneProvider
- Your add-in's implementation of the IDockablePaneProvider interface.

Exception | Condition |
---|---|
ArgumentException | Thrown if a dockable pane with identifier %id% has already been registered. |

public Result OnStartup(UIControlledApplication application)
{
// Create our pane provider and register it with the application
PaneProvider prov = new PaneProvider();
DockablePaneId id = new DockablePaneId(Guid.NewGuid());
application.RegisterDockablePane(id, "test", prov);
return Result.Succeeded;
}