Creates a new instance of a mechanical system type and adds it to the document.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The document where the element will be created and added.
- systemClassification
- Type: Autodesk.Revit.DB MEPSystemClassification
The classification for the mechanical system type to be created
- name
- Type: System String
The name of the mechanical system type to be created.
Return Value
The newly created mechanical system type element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The system classification is not valid for the domain of this system type. |