Create Method


Mechanical System Type Create Method

Creates a new instance of a mechanical system type and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static MechanicalSystemType Create(
	Document ADoc,
	MEPSystemClassification systemClassification,
	string name
)

Parameters

ADoc Document
The document where the element will be created and added.
systemClassification MEPSystemClassification
The classification for the mechanical system type to be created
name String
The name of the mechanical system type to be created.

Return Value

MechanicalSystemType
The newly created mechanical system type element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException The system classification is not valid for the domain of this system type.
See Also