Obtains a set of types that are valid for all given elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- elementIds
- Type: System.Collections.Generic ICollection ElementId
A collection of element IDs.
Return Value
A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when at least one of the elements does not exist in the document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |