Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- matchExtResRef
- Type: Autodesk.Revit.DB ExternalResourceReference
An ExternalResourceReference whose LinkLoadResults are contained in this object.
Return Value
A LinkLoadResult object with the load results for the specified ExternalResourceReference.Remarks
In the case where there are multiple matches, then the LinkLoadResult closest to the top-level link will be returned. For example, if you are searching for C, starting with a top-level link, A, which links B and C, while B also links C directly, then the load results for C as a direct sub-link of A will be returned. It is expected that the LinkLoadResults for all instances of C in the nested load result tree will be the same. However, if you need to inspect each individual result, the LinkLoadResult class does provide methods to navigate the tree.
NULL is returned if a match for the ExternalResourceReference cannot be found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |