Link |
Searches this LinkLoadResult and all nested LinkLoadResults for the load operation results of a specified ExternalResourceReference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- matchExtResRef ExternalResourceReference
- An ExternalResourceReference whose LinkLoadResults are contained in this object.
Return Value
LinkLoadResultA LinkLoadResult object with the load results for the specified ExternalResourceReference.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

In the case where there are multiple matches, then the LinkLoadResult closest to the top-level link will be returned. For example, if you are searching for C, starting with a top-level link, A, which links B and C, while B also links C directly, then the load results for C as a direct sub-link of A will be returned. It is expected that the LinkLoadResults for all instances of C in the nested load result tree will be the same. However, if you need to inspect each individual result, the LinkLoadResult class does provide methods to navigate the tree.
NULL is returned if a match for the ExternalResourceReference cannot be found.