Checks whether the element supports sketch editing.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elemId
- Type: Autodesk.Revit.DB ElementId
The element id to be checked.
Return Value
True if element supports sketch editing, false otherwise.Remarks
This method checks if the element supports edit to all its sketches. If you want to check if this element supports edit to a particular sketch please use IsSketchEditingSupported(ElementId) .
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |