IsSketchEditingSupportedForSketchBasedElement Method


Checks whether the element supports sketch editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public bool IsSketchEditingSupportedForSketchBasedElement(
	ElementId elemId
)
Visual Basic
Public Function IsSketchEditingSupportedForSketchBasedElement ( _
	elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsSketchEditingSupportedForSketchBasedElement(
	ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DBElementId
The element id to be checked.

Return Value

True if element supports sketch editing, false otherwise.

Remarks

This method checks if the element supports edit to all its sketches. If you want to check if this element supports edit to a particular sketch please use IsSketchEditingSupported(ElementId).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also