Create a rebar shape definition with a given number of segments.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
A document. The definition object is not a part of the document, but it will contain references to parameters that are in a document. The definition can be used for RebarShape creation only in the specified document.
- numberOfSegments
- Type: System Int32
The number of segments in the definition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | numberOfSegments must be at least 1. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |