RebarShapeDefinitionBySegments Constructor


Rebar Shape Definition By Segments Constructor

Create a rebar shape definition with a given number of segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeDefinitionBySegments(
	Document doc,
	int numberOfSegments
)

Parameters

doc Document
A document. The definition object is not a part of the document, but it will contain references to parameters that are in a document. The definition can be used for RebarShape creation only in the specified document.
numberOfSegments Int32
The number of segments in the definition.
Exceptions
Exception Condition
ArgumentException numberOfSegments must be at least 1.
ArgumentNullException A non-optional argument was null
See Also