IsValidReferenceName Method


Validates that the input name can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public static bool IsValidReferenceName(
	string name
)
Visual Basic
Public Shared Function IsValidReferenceName ( _
	name As String _
) As Boolean
Visual C++
public:
static bool IsValidReferenceName(
	String^ name
)

Parameters

name
Type: System String
The name to assign to the reference.

Return Value

True if the input name is valid, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also