IsValidReferenceName Method


Direct Shape Reference Options Is Valid Reference Name Method

Validates that the input name can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidReferenceName(
	string name
)

Parameters

name String
The name to assign to the reference.

Return Value

Boolean
True if the input name is valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also